GHSA-xh29-r2w5-wx8mHighCVSS 8.2

Nokogiri Improperly Handles Unexpected Data Type

Published
May 23, 2022
Last Modified
May 27, 2025

🔗 CVE IDs covered (1)

📋 Description

Summary

Nokogiri < v1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers. For CRuby users, this may allow specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory.

Severity

The Nokogiri maintainers have evaluated this as High 8.2 (CVSS3.1).

Mitigation

CRuby users should upgrade to Nokogiri >= 1.13.6.

JRuby users are not affected.

Workarounds

To avoid this vulnerability in affected applications, ensure the untrusted input is a String by calling #to_s or equivalent.

Credit

This vulnerability was responsibly reported by @agustingianni and the Github Security Lab.

🎯 Affected products1

  • rubygems/nokogiri:< 1.13.6

🔗 References (11)