GHSA-xx7v-hqxh-cjr9HighCVSS 7.5

Apache Struts is Vulnerable to DoS via File Leak

Published
December 1, 2025
Last Modified
December 3, 2025

🔗 CVE IDs covered (1)

📋 Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.

This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.

Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

🎯 Affected products4

  • maven/org.apache.struts:struts2-core:>= 6.0.0, < 6.8.0
  • maven/org.apache.struts:struts2-core:>= 7.0.0, < 7.1.1
  • maven/org.apache.struts:struts2-core:>= 2.0.0, <= 2.3.37
  • maven/org.apache.struts:struts2-core:>= 2.5.0, <= 2.5.33

🔗 References (4)