GHSA-xf5p-87ch-gxw2MediumCVSS 5.3Disclosed before NVD

Marked ReDoS due to email addresses being evaluated in quadratic time

Published
June 5, 2019
Last Modified
January 11, 2023

📋 Description

Versions of marked from 0.3.14 until 0.6.2 are vulnerable to Regular Expression Denial of Service. Email addresses may be evaluated in quadratic time, allowing attackers to potentially crash the node process due to resource exhaustion.

Recommendation

Upgrade to version 0.6.2 or later.

🎯 Affected products1

  • npm/marked:>= 0.3.14, < 0.6.2

🔗 References (6)