GHSA-xf27-jqwv-gf3rHighCVSS 7.5
Unintended Require in larvitbase-api
🔗 CVE IDs covered (1)
📋 Description
Versions of larvitbase-api prior to 0.5.4 are vulnerable to an Unintended Require. The package exposes an API endpoint and passes a GET parameter unsanitized to an require() call. This allows attackers to execute any .js file in the same folder as the server is running.
Recommendation
Upgrade to version 0.5.4 or later.
🎯 Affected products1
- npm/larvitbase-api:< 0.5.5