GHSA-x6fg-f45m-jf5qHighCVSS 7.5

Regular Expression Denial of Service in semver

Published
October 24, 2017
Last Modified
March 3, 2026

🔗 CVE IDs covered (1)

📋 Description

Versions 4.3.1 and earlier of semver are affected by a regular expression denial of service vulnerability when extremely long version strings are parsed.

Recommendation

Update to version 4.3.2 or later

🎯 Affected products1

  • npm/semver:>= 1.0.4, < 4.3.2

🔗 References (9)