GHSA-x684-96hh-833xHighCVSS 8.0

Craft CMS has a potential RCE with a compromised security key

Published
January 21, 2025
Last Modified
October 22, 2025

🔗 CVE IDs covered (1)

📋 Description

Impact

This is an RCE vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised.

https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret

Anyone running an unpatched version of Craft with a compromised security key is affected.

Patches

This has been patched in Craft 5.5.8 and 4.13.8.

Workarounds

If you can't update to a patched version, then rotating your security key and ensuring its privacy will help to migitgate the issue.

References

https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603

🎯 Affected products2

  • composer/craftcms/cms:>= 5.0.0-RC1, < 5.5.5
  • composer/craftcms/cms:>= 4.0.0-RC1, < 4.13.8

🔗 References (6)