GHSA-wph3-44rj-92prCriticalCVSS 9.8

elFinder before 2.1.59 contains multiple vulnerabilities leading to RCE

Published
June 16, 2021
Last Modified
January 29, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

We recently fixed several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with the minimal configuration.

Patches

The issues were addressed in our last release, 2.1.59.

Workarounds

If you can't update to 2.1.59, make sure your connector is not exposed without authentication.

Reference

Further technical details will be disclosed on https://blog.sonarsource.com/tag/security after some time.

For more information

If you have any questions or comments about this advisory, you can contact: - The original reporters, by sending an email to [email protected]; - The maintainers, by opening an issue on this repository.

🎯 Affected products1

  • composer/studio-42/elfinder:< 2.1.59

🔗 References (7)