GHSA-wp3j-rvfp-624hHigh

RubyGems vulnerable to DNS hijack attack

Published
May 14, 2022
Last Modified
August 25, 2023

🔗 CVE IDs covered (1)

📋 Description

RubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.4, and 2.4.x before 2.4.7 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record, aka a "DNS hijack attack."

🎯 Affected products3

  • rubygems/rubygems-update:>= 2.0.0, < 2.0.16
  • rubygems/rubygems-update:>= 2.2.0, < 2.2.4
  • rubygems/rubygems-update:>= 2.4.0, < 2.4.7

🔗 References (15)