GHSA-wmx6-vxcf-c3grCriticalCVSS 5.7

Validation Bypass in slp-validate

Published
November 15, 2019
Last Modified
January 9, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions of slp-validate prior to 1.0.1 are vulnerable to a validation bypass. Bitcoin scripts may cause the validation result from slp-validate to differ from the specified SLP consensus. This allows an attacker to create a Bitcoin script that causes a hard-fork from the SLP consensus.

Recommendation

Upgrade to version 1.0.1 or later.

🎯 Affected products1

  • npm/slp-validate:= 1.0.0

🔗 References (5)