GHSA-wjmp-wphq-jvqfCritical

Passport-wsfed-saml2 allows SAML Authentication Bypass via Signature Wrapping

Published
May 6, 2025
Last Modified
May 6, 2025

🔗 CVE IDs covered (1)

📋 Description

Overview

This vulnerability allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP.

Am I Affected?

You are affected by this SAML Signature Wrapping vulnerability if you are using passport-wsfed-saml2 version 4.6.3 or below, specifically under the following conditions:

  1. The service provider is using passport-wsfed-saml2,
  2. A valid SAML document signed by the Identity Provider can be obtained.

Fix

Upgrade to v4.6.4 or greater.

🎯 Affected products1

  • npm/passport-wsfed-saml2:>= 3.0.5, <= 4.6.3

🔗 References (4)