GHSA-w749-p3v6-hccqCriticalCVSS 9.8

Possible code injection vulnerability in Rails / Active Storage

Published
March 8, 2022
Last Modified
March 22, 2023

🔗 CVE IDs covered (1)

📋 Description

The Active Storage module of Rails starting with version 5.2.0 is possibly vulnerable to code injection. This issue was patched in versions 5.2.6.3, 6.0.4.7, 6.1.4.7, and 7.0.2.3. To work around this issue, applications should implement a strict allow-list on accepted transformation methods or arguments. Additionally, a strict ImageMagick security policy will help mitigate this issue.

🎯 Affected products4

  • rubygems/activestorage:>= 5.2.0, <= 5.2.6.2
  • rubygems/activestorage:>= 6.0.0, <= 6.0.4.6
  • rubygems/activestorage:>= 6.1.0, <= 6.1.4.6
  • rubygems/activestorage:>= 7.0.0, <= 7.0.2.2

🔗 References (9)