GHSA-w73q-mc9g-j56xHighCVSS 7.5

Asset Pipeline Grails Plugin vulnerable to Path Traversal

Published
May 13, 2022
Last Modified
February 2, 2023

🔗 CVE IDs covered (1)

📋 Description

Asset Pipeline Grails Plugin Asset-pipeline plugin version Prior to 2.14.1.1, 2.15.1 and 3.0.6 contains a Incorrect Access Control vulnerability in Applications deployed in Jetty that can result in Download .class files and any arbitrary file. This attack appear to be exploitable via Specially crafted GET request containing directory traversal from assets-pipeline context. This vulnerability appears to have been fixed in 2.14.1.1 (for Grails 2.x), 2.15.1 (for Grails 3 and Java 7) and 3.0.6 (for Grails 3 and Java 8).

🎯 Affected products3

  • maven/org.grails.plugins:asset-pipeline:< 2.14.1
  • maven/org.grails.plugins:asset-pipeline:= 2.15.0
  • maven/org.grails.plugins:asset-pipeline:>= 3.0.0, < 3.0.6

🔗 References (4)