GHSA-w729-7633-2fw5CriticalCVSS 9.8

Deserialization of Untrusted Data leading to Remote Code Execution in Apache Storm

Published
October 27, 2021
Last Modified
February 1, 2023

🔗 CVE IDs covered (1)

📋 Description

An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4

🎯 Affected products3

  • maven/org.apache.storm:storm:>= 2.2.0, < 2.2.1
  • maven/org.apache.storm:storm:>= 1.0.0, < 1.2.4
  • maven/org.apache.storm:storm:>= 2.1.0, < 2.1.1

🔗 References (4)