GHSA-w457-6q6x-cgp9CriticalCVSS 9.8

Prototype Pollution in handlebars

Published
December 26, 2019
Last Modified
February 12, 2025

🔗 CVE IDs covered (1)

📋 Description

Versions of handlebars prior to 3.0.8 or 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution. Templates may alter an Objects' __proto__ and __defineGetter__ properties, which may allow an attacker to execute arbitrary code through crafted payloads.

Recommendation

Upgrade to version 3.0.8, 4.3.0 or later.

🎯 Affected products3

  • npm/handlebars:>= 4.0.0, < 4.3.0
  • rubygems/bootstrap-wysihtml5-rails:>= 0.3.3.5, <= 0.3.3.8
  • npm/handlebars:< 3.0.8

🔗 References (11)