GHSA-vxm9-8mfw-vc6gHighCVSS 8.2
Hermes improperly validates a JWT
🔗 CVE IDs covered (1)
📋 Description
Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.
🎯 Affected products1
- go/github.com/hashicorp-forge/hermes:< 0.5.0
🔗 References (4)
- https://nvd.nist.gov/vuln/detail/CVE-2025-1293
- https://discuss.hashicorp.com/t/hcsec-2025-03-hashicorp-hermes-improperly-validates-aws-alb-jwts-which-may-lead-to-authentication-bypass/73371
- https://github.com/hashicorp-forge/hermes/commit/e36d479616099bd0c8dfde6786ea671f112d9106
- https://github.com/advisories/GHSA-vxm9-8mfw-vc6g