GHSA-vxhx-gmhm-623cHighCVSS 7.5

Improper Access Control in moodle

Published
March 29, 2021
Last Modified
February 4, 2024

🔗 CVE IDs covered (1)

📋 Description

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

🎯 Affected products4

  • composer/moodle/moodle:>= 3.9.0, < 3.9.3
  • composer/moodle/moodle:>= 3.8.0, < 3.8.6
  • composer/moodle/moodle:>= 3.7.0, < 3.7.9
  • composer/moodle/moodle:>= 3.5, < 3.5.15

🔗 References (8)