GHSA-v9m8-9xxp-q492Critical

Auth0-PHP SDK Deserialization of Untrusted Data vulnerability

Published
June 4, 2025
Last Modified
June 4, 2025

🔗 CVE IDs covered (1)

📋 Description

Overview The Auth0 PHP SDK contains a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.

Am I Affected? You are affected by this vulnerability if you meet the following preconditions:

  1. Applications using the Auth0-PHP SDK, versions between 8.0.0-BETA3 to 8.3.0.
  2. Applications using the following SDKs that rely on the Auth0-PHP SDK versions between 8.0.0-BETA3 to 8.3.0: a. Auth0/symfony, b. Auth0/laravel-auth0, c. Auth0/wordpress.

Fix Upgrade Auth0/Auth0-PHP to 8.3.1.

Acknowledgement Okta would like to thank Andreas Forsblom for discovering this vulnerability.

🎯 Affected products1

  • composer/auth0/auth0-php:>= 8.0.0-BETA3, < 8.3.1

🔗 References (7)