GHSA-v6rp-3r3v-hf4pHighCVSS 7.5

Ruby OpenSSL DoS Vulnerability

Published
May 14, 2022
Last Modified
October 24, 2023

🔗 CVE IDs covered (1)

📋 Description

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string. The openssl gem that contains this module is patched in version 2.0.0.

🎯 Affected products1

  • rubygems/openssl:< 2.0.0

🔗 References (16)