GHSA-v6mg-96c6-gmpqLowCVSS 3.1
CKEditor: Cross-site scripting (XSS) in the engine package
🔗 CVE IDs covered (1)
📋 Description
Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.
This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.
Patches
The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
🎯 Affected products4
- npm/ckeditor5:>= 29.0.0, < 47.7.4
- npm/@ckeditor/ckeditor5-engine:>= 29.0.0, < 47.7.4
- npm/ckeditor5:>= 48.0.0, < 48.5.1
- npm/@ckeditor/ckeditor5-engine:>= 48.0.0, < 48.5.1
🔗 References (6)
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-v6mg-96c6-gmpq
- https://github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0
- https://github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423
- https://github.com/ckeditor/ckeditor5/releases/tag/v47.7.4
- https://github.com/ckeditor/ckeditor5/releases/tag/v48.5.1
- https://github.com/advisories/GHSA-v6mg-96c6-gmpq