GHSA-v588-qcp3-jv46HighCVSS 7.5
Path Traversal in serve
🔗 CVE IDs covered (1)
📋 Description
Versions of serve prior to 7.0.1 are vulnerable to Path Traversal. Explicitly ignored folders can be accessed through if the path contains a /./, which allows attackers to access hidden folders and files.
Recommendation
Upgrade to version 7.0.1 or later.
🎯 Affected products1
- npm/serve:< 7.0.0