GHSA-v2wj-7wpq-c8vvMediumCVSS 6.1

DOMPurify contains a Cross-site Scripting vulnerability

Published
March 3, 2026
Last Modified
March 30, 2026

🔗 CVE IDs covered (1)

📋 Description

DOMPurify 3.1.3 through 3.3.1 and 2.5.3 through 2.5.8, fixed in 2.5.9 and 3.3.2, contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting five missing rawtext elements (noscript, xmp, noembed, noframes, iframe) in the SAFE_FOR_XML regex. Attackers can include payloads like </noscript><img src=x onerror=alert(1)> in attribute values to execute JavaScript when sanitized output is placed inside these unprotected rawtext contexts.

🎯 Affected products2

  • npm/dompurify:>= 3.1.3, <= 3.3.1
  • npm/dompurify:>= 2.5.3, <= 2.5.8

🔗 References (8)