GHSA-rxgg-273w-rfw7HighCVSS 9.8
Remote Code Execution vulnerability in Apache IoTDB via UDF
🔗 CVE IDs covered (1)
📋 Description
Remote Code Execution vulnerability in Apache IoTDB. This issue affects Apache IoTDB from 1.0.0 through 1.2.2.
Users are recommended to upgrade to version 1.3.0, which fixes the issue.
🎯 Affected products2
- maven/org.apache.iotdb:iotdb-core:>= 1.0.0, <= 1.2.2
- pip/apache-iotdb:>= 1.0.0, < 1.3.0
🔗 References (5)
- https://nvd.nist.gov/vuln/detail/CVE-2023-46226
- https://lists.apache.org/thread/293b4ob65ftnfwyf62fb9zh8gwdy38hg
- http://www.openwall.com/lists/oss-security/2024/01/15/1
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-iotdb/PYSEC-2024-11.yaml
- https://github.com/advisories/GHSA-rxgg-273w-rfw7