GHSA-rv8p-rr2h-fgpgHighCVSS 8.2

@apollo/experimental-nextjs-app-support Cross-site Scripting vulnerability

Published
January 30, 2024
Last Modified
January 30, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. This vulnerability arises from improper handling of untrusted input when @apollo/experimental-apollo-client-nextjs performs server-side rendering of HTML pages. To fix this vulnerability, we implemented appropriate escaping to prevent javascript injection into rendered pages.

Patches

To fix this issue, please update to version 0.7.0 or later.

Workarounds

There are no known workarounds for this issue. Please update to version 0.7.0

🎯 Affected products1

  • npm/@apollo/experimental-nextjs-app-support:<= 0.6.0

🔗 References (4)