GHSA-rrp4-2xx3-mv29MediumCVSS 6.8

Command injection in gh-ost

Published
February 1, 2022
Last Modified
February 3, 2023

🔗 CVE IDs covered (1)

📋 Description

Gh-ost version <= 1.1.2 allows users to inject DSN strings via the -database parameter.

This is a low severity vulnerability as the attacker must have access to the target host or trick an administrator into executing a malicious gh-ost command on a host running gh-ost, plus network access from host running gh-ost to the attack's malicious MySQL server.

Impact

This issue may lead to arbitrary local file read.

Patches

Fixed in 1.1.3+.

Workarounds

None

References

  • https://advisory.dw1.io/51

For more information

If you have any questions or comments about this advisory:

🎯 Affected products1

  • go/github.com/github/gh-ost:< 1.1.3

🔗 References (4)