GHSA-rh54-vffm-5fvpHighCVSS 8.1
CKEditor: Cross-site scripting (XSS) in the engine package
🔗 CVE IDs covered (1)
📋 Description
Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.
The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.
Patches
The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
🎯 Affected products4
- npm/ckeditor5:>= 45.0.0, < 47.7.4
- npm/@ckeditor/ckeditor5-engine:>= 45.0.0, < 47.7.4
- npm/ckeditor5:>= 48.0.0, < 48.5.1
- npm/@ckeditor/ckeditor5-engine:>= 48.0.0, < 48.5.1
🔗 References (6)
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-rh54-vffm-5fvp
- https://github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0
- https://github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423
- https://github.com/ckeditor/ckeditor5/releases/tag/v47.7.4
- https://github.com/ckeditor/ckeditor5/releases/tag/v48.5.1
- https://github.com/advisories/GHSA-rh54-vffm-5fvp