GHSA-rg58-xhh7-mqjwHighCVSS 8.2

Apache Struts has a Denial of Service vulnerability

Published
December 10, 2025
Last Modified
December 10, 2025

🔗 CVE IDs covered (1)

📋 Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.

This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3.

Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

🎯 Affected products2

  • maven/org.apache.struts:struts2-core:>= 2.0.0, < 6.8.0
  • maven/org.apache.struts:struts2-core:>= 7.0.0, < 7.1.1

🔗 References (5)