GHSA-r5xw-q988-826mMediumCVSS 5.1Disclosed before NVD
Remote Memory Exposure in mongoose
📋 Description
Versions of mongoose before 4.3.6, 3.8.39 are vulnerable to remote memory exposure.
Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database.
Recommendation
Update to version 4.3.6, 3.8.39 or later.
🎯 Affected products2
- npm/mongoose:>= 3.5.5, <= 3.8.38
- npm/mongoose:>= 4.0.0, <= 4.3.5