GHSA-r3jc-vhf4-6v32MediumCVSS 6.8

CKAN has Cross-site Scripting vector in the Datatables view plugin

Published
August 21, 2024
Last Modified
August 21, 2024

🔗 CVE IDs covered (1)

📋 Description

The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector.

Impact

Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data.

Patches

This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0

Workarounds

Prevent importing of tabular files to the DataStore via DataPusher, XLoader,etc, at least those published from untrusted sources.

🎯 Affected products1

  • pip/ckan:>= 2.7.0, < 2.10.5

🔗 References (5)