GHSA-qvqm-h22r-4cp9HighCVSS 8.1
Laravel Framework RCE Vulnerability
🔗 CVE IDs covered (1)
📋 Description
In Laravel Framework through 5.5.40 and 5.6.x through 5.6.29, remote code execution might occur as a result of an unserialize call on a potentially untrusted X-XSRF-TOKEN value. This involves the decrypt method in Illuminate/Encryption/Encrypter.php and PendingBroadcast in gadgetchains/Laravel/RCE/3/chain.php in phpggc. The attacker must know the application key, which normally would never occur, but could happen if the attacker previously had privileged access or successfully accomplished a previous attack.
🎯 Affected products2
- composer/laravel/framework:<= 5.5.40
- composer/laravel/framework:>= 5.6.0, <= 5.6.29
🔗 References (6)
- https://nvd.nist.gov/vuln/detail/CVE-2018-15133
- https://laravel.com/docs/5.6/upgrade#upgrade-5.6.30
- http://packetstormsecurity.com/files/153641/PHP-Laravel-Framework-Token-Unserialize-Remote-Command-Execution.html
- https://github.com/laravel/framework/commit/d84cf988ed5d4661a4bf1fdcb08f5073835083a0
- https://github.com/kozmic/laravel-poc-CVE-2018-15133
- https://github.com/advisories/GHSA-qvqm-h22r-4cp9