GHSA-qv62-xfj6-32xmMedium

RubyGems Improper Input Validation vulnerability

Published
May 17, 2022
Last Modified
May 4, 2023

🔗 CVE IDs covered (1)

📋 Description

RubyGems 2.0.x before 2.0.17, 2.2.x before 2.2.5, and 2.3.x before 2.4.8 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record with a domain that is suffixed with the original domain name, aka a "DNS hijack attack."

NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-3900.

🎯 Affected products3

  • rubygems/rubygems-update:< 2.0.17
  • rubygems/rubygems-update:>= 2.1.0.rc.1, < 2.2.5
  • rubygems/rubygems-update:>= 2.3.0, < 2.4.8

🔗 References (13)