GHSA-qhmp-h54x-38qrHighCVSS 7.5

Apprise vulnerable to regex injection with IFTTT Plugin

Published
September 20, 2021
Last Modified
September 12, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

Anyone publicly hosting the Apprise library and granting them access to the IFTTT notification service.

Patches

Update to Apprise v0.9.5.1

# Install Apprise v0.9.5.1 from PyPI
pip install apprise==0.9.5.1

The patch to the problem was performed here.

Workarounds

Alternatively, if upgrading is not an option, you can safely remove the following file:

  • apprise/plugins/NotifyIFTTT.py

The above will eliminate the ability to use IFTTT, but everything else will work smoothly.

For more information

If you have any questions or comments about this advisory:

Additional Credit

Github would not allow me to additionally credit Rasmus Petersen, but I would like to put that here at the very least - thank you for finding and reporting this issue along with those already credited

Additional Notes:

  • Github would not allow me to add/tag the 2 CWE's this issue is applicable to (only CWE-400). The other is: CWE-730 (placed in the title)

🎯 Affected products1

  • pip/apprise:<= 0.9.4

🔗 References (8)