GHSA-q4m3-2j7h-f7xwMediumCVSS 6.1

Cross-Site Scripting in jquery

Published
May 20, 2020
Last Modified
October 10, 2024

🔗 CVE IDs covered (1)

📋 Description

Versions of jquery prior to 1.9.0 are vulnerable to Cross-Site Scripting. The load method fails to recognize and remove <script> HTML tags that contain a whitespace character, i.e: </script >, which results in the enclosed script logic to be executed. This allows attackers to execute arbitrary JavaScript in a victim's browser.

Recommendation

Upgrade to version 1.9.0 or later.

🎯 Affected products4

  • rubygems/jquery-rails:< 2.2.0
  • npm/jquery:>= 1.2.1, < 1.9.0
  • nuget/jQuery:>= 1.2.1, < 1.9.0
  • maven/org.webjars.npm:jquery:>= 1.2.1, < 1.9.0

🔗 References (12)