GHSA-pm9x-4392-2c2pHighCVSS 7.5

RubyGems may allow a maliciously crafted gem to overwrite files

Published
May 13, 2022
Last Modified
March 9, 2023

🔗 CVE IDs covered (1)

📋 Description

RubyGems versions 2.6.12 and earlier fail to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

🎯 Affected products1

  • rubygems/rubygems-update:< 2.6.13

🔗 References (17)