GHSA-pfj7-2qfw-vwgmMediumCVSS 5.0

NodeBB vulnerable to path traversal in translator module

Published
November 30, 2021
Last Modified
February 1, 2023

🔗 CVE IDs covered (1)

📋 Description

Impact

Prior to v1.18.5, a path traversal vulnerability was present that allowed users to access JSON files outside of the expected languages/ directory.

Patches

The vulnerability has been patched as of v1.18.5.

Workarounds

Cherry-pick commit hash c8b2fc46dc698db687379106b3f01c71b80f495f to receive this patch in lieu of a full upgrade.

For more information

If you have any questions or comments about this advisory:

🎯 Affected products1

  • npm/nodebb:>= 1.0.4, < 1.18.5

🔗 References (6)