GHSA-p783-gj6m-9r88HighCVSS 8.8
Magento 2 Community Edition RCE Vulnerability
🔗 CVE IDs covered (1)
📋 Description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to manipulate layouts and images can insert a malicious payload into the page layout.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
🎯 Affected products2
- composer/magento/community-edition:>= 2.2.0, < 2.2.10
- composer/magento/community-edition:>= 2.3.0, < 2.3.2-p2
🔗 References (5)
- https://nvd.nist.gov/vuln/detail/CVE-2019-8150
- https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8150.yaml
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://github.com/advisories/GHSA-p783-gj6m-9r88