GHSA-p76j-5v6v-6c22HighCVSS 7.5

Apache NiFi JMS Deserialization issue

Published
May 14, 2022
Last Modified
January 30, 2023

🔗 CVE IDs covered (1)

📋 Description

Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. Malicious JMS content could cause denial of service. See ActiveMQ CVE-2015-5254 announcement for more information. The fix to upgrade the activemq-client library to 5.15.3 was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.

🎯 Affected products1

  • maven/org.apache.nifi:nifi:< 1.6.0

🔗 References (3)