GHSA-p72w-r6fv-6g5hLowCVSS 3.7

druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability

Published
September 17, 2024
Last Modified
March 14, 2025

🔗 CVE IDs covered (1)

📋 Description

Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie.

This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability.

While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.

🎯 Affected products1

  • maven/org.apache.druid.extensions:druid-pac4j:>= 0.18.0, < 30.0.1

🔗 References (6)