GHSA-p4v8-rw59-93cqMediumCVSS 6.1

Wagtail Vulnerable to Cross-site Scripting in simple_translation admin interface

Published
March 3, 2026
Last Modified
March 5, 2026

🔗 CVE IDs covered (1)

📋 Description

Impact

A stored Cross-site Scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.

Patches

Patched versions have been released as Wagtail 6.3.8, 7.0.6, 7.2.3 and 7.3.1.

Workarounds

None

Acknowledgements

Many thanks to Guan Chenxian (@GCXWLP) for reporting this issue.

For more information

If there are any questions or comments about this advisory:

🎯 Affected products4

  • pip/wagtail:< 6.3.8
  • pip/wagtail:>= 6.4rc1, < 7.0.6
  • pip/wagtail:>= 7.1rc1, < 7.2.3
  • pip/wagtail:>= 7.3rc1, < 7.3.1

🔗 References (11)