GHSA-p48w-vf3c-rqjxMediumCVSS 5.4

Cross-Site Scripting in Bootstrap Package

Published
April 29, 2021
Last Modified
February 1, 2023

🔗 CVE IDs covered (1)

📋 Description

Problem

It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability.

The following templates are affected by the vulnerability:

  • Resources/Private/Partials/ContentElements/Carousel/Item/CallToAction.html
  • Resources/Private/Partials/ContentElements/Carousel/Item/Header.html
  • Resources/Private/Partials/ContentElements/Carousel/Item/Text.html
  • Resources/Private/Partials/ContentElements/Carousel/Item/TextAndImage.html
  • Resources/Private/Partials/ContentElements/Header/SubHeader.html

Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix as shown in this Git commit.

Solution

Update to version 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described.

Updated version are available from the TYPO3 extension manager, Packagist and at https://extensions.typo3.org/extension/download/bootstrap_package/.

Credits

Thanks to TYPO3 security team member Oliver Hader who reported and fixed the issue.

🎯 Affected products6

  • composer/bk2k/bootstrap-package:>= 7.1.0, < 7.1.2
  • composer/bk2k/bootstrap-package:>= 8.0.0, < 8.0.8
  • composer/bk2k/bootstrap-package:>= 9.0.0, < 9.0.4
  • composer/bk2k/bootstrap-package:>= 9.1.0, < 9.1.3
  • composer/bk2k/bootstrap-package:>= 10.0.0, < 10.0.10
  • composer/bk2k/bootstrap-package:>= 11.0.0, < 11.0.3

🔗 References (5)