GHSA-mqwr-4qf2-2hcvCriticalCVSS 9.8

RubyGems vulnerable to Deserialization of Untrusted Data

Published
May 13, 2022
Last Modified
March 9, 2023

🔗 CVE IDs covered (1)

📋 Description

RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution. The issue has been patched in 2.6.14.

🎯 Affected products1

  • rubygems/rubygems-update:>= 2.0.0, < 2.6.14

🔗 References (15)