GHSA-mm33-5vfq-3mm3MediumCVSS 6.1

Cross-site Scripting Vulnerability in Action Pack

Published
April 27, 2022
Last Modified
April 13, 2023

🔗 CVE IDs covered (1)

📋 Description

There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577.

Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1

Impact

CSP headers were only sent along with responses that Rails considered as "HTML" responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks.

Releases

The FIXED releases are available at the normal locations.

Workarounds

Set a CSP for your API responses manually.

🎯 Affected products4

  • rubygems/actionpack:>= 5.2.0, <= 5.2.7.0
  • rubygems/actionpack:>= 6.0.0, <= 6.0.4.7
  • rubygems/actionpack:>= 6.1.0, <= 6.1.5.0
  • rubygems/actionpack:>= 7.0.0, <= 7.0.2.3

🔗 References (14)