GHSA-mj7q-cmf3-mg7hMediumCVSS 5.4

Stored XSS vulnerability in Jenkins on new item page

Published
May 24, 2022
Last Modified
December 14, 2023

🔗 CVE IDs covered (1)

📋 Description

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not escape display names and IDs of item types shown on the New Item page.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to specify display names or IDs of item types.

As of the publication of this advisory, the Jenkins security team is not aware of any plugins published via the Jenkins project update center that allow doing this. Jenkins 2.275, LTS 2.263.2 escapes display names and IDs of item types shown on the New Item page.

🎯 Affected products2

  • maven/org.jenkins-ci.main:jenkins-core:<= 2.263.1
  • maven/org.jenkins-ci.main:jenkins-core:>= 2.264, <= 2.274

🔗 References (4)