GHSA-mhwm-jh88-3gjfMediumCVSS 4.0

CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement

Published
March 3, 2025
Last Modified
November 4, 2025

🔗 CVE IDs covered (1)

📋 Description

There is a possibility for Regular expression Denial of Service (ReDoS) by in the cgi gem. This vulnerability has been assigned the CVE identifier CVE-2025-27220. We recommend upgrading the cgi gem.

Details

The regular expression used in CGI::Util#escapeElement is vulnerable to ReDoS. The crafted input could lead to a high CPU consumption.

This vulnerability only affects Ruby 3.1 and 3.2. If you are using these versions, please update CGI gem to version 0.3.5.1, 0.3.7, 0.4.2 or later.

Affected versions

cgi gem versions <= 0.3.5, 0.3.6, 0.4.0 and 0.4.1.

Credits

Thanks to svalkanov for discovering this issue. Also thanks to nobu for fixing this vulnerability.

🎯 Affected products3

  • rubygems/cgi:< 0.3.5.1
  • rubygems/cgi:= 0.3.6
  • rubygems/cgi:>= 0.4.0, < 0.4.2

🔗 References (10)