GHSA-mf2p-h6hf-fcwmHigh

TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization

Published
October 27, 2026
Last Modified
October 27, 2026

🔗 CVE IDs covered (1)

📋 Description

Impact

Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.

Patches

This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.

Workarounds

No official workaround available.

Fix

To avoid this vulnerability:

Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher.

Acknowledgements

Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.

🎯 Affected products6

  • npm/tinymce:>= 8.5.1, < 8.9.3
  • nuget/TinyMCE:>= 8.5.1, < 8.9.3
  • composer/tinymce/tinymce:>= 8.5.1, < 8.9.3
  • npm/tinymce:= 7.9.3
  • nuget/TinyMCE:= 7.9.3
  • composer/tinymce/tinymce:= 7.9.3

🔗 References (7)