GHSA-mcrp-whpw-jp68CriticalCVSS 9.8

InvokeAI Deserialization of Untrusted Data vulnerability

Published
March 21, 2025
Last Modified
May 20, 2025

🔗 CVE IDs covered (1)

📋 Description

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3rc2.

🎯 Affected products1

  • pip/InvokeAI:>= 5.3.1, < 5.4.3rc2

🔗 References (6)