GHSA-mc6j-h948-v2p6CriticalCVSS 9.8

RubyGems Improper Verification of Cryptographic Signature vulnerability

Published
May 14, 2022
Last Modified
March 8, 2023

🔗 CVE IDs covered (1)

📋 Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, and Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contain an Improper Verification of Cryptographic Signature vulnerability in package.rb. This can result in a mis-signed gem being installed, as the tarball would contain multiple gem signatures. This vulnerability has been fixed in 2.7.6.

🎯 Affected products2

  • rubygems/rubygems-update:>= 2.2.0, < 2.7.6
  • maven/org.jruby:jruby-stdlib:< 9.1.16.0

🔗 References (21)