GHSA-m75h-cghq-c8h5Critical

Heap Based Buffer Overflow in libyaml

Published
August 31, 2020
Last Modified
September 7, 2023

🔗 CVE IDs covered (1)

📋 Description

Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags.

Recommendation

  • Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.

🎯 Affected products1

  • npm/libyaml:< 0.2.3

🔗 References (25)