GHSA-m6jm-3v38-76j4MediumCVSS 4.3
Apache Superset: Improper Neutralization of custom SQL on embedded context
🔗 CVE IDs covered (1)
📋 Description
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
🎯 Affected products2
- pip/apache-superset:<= 3.0.3
- pip/apache-superset:>= 3.1.0, < 3.1.1