GHSA-jr3j-whm4-9wwmHighCVSS 8.1
Reflected XSS when using flashMessages or languageDictionary
🔗 CVE IDs covered (1)
📋 Description
Overview
Versions before and including 11.30.0 are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's
flashMessagefeature is utilized and user input or data from URL parameters is incorporated into theflashMessage.languageDictionaryfeature is utilized and user input or data from URL parameters is incorporated into thelanguageDictionary.
Am I affected?
You are affected by this vulnerability if you are using auth0-lock version 11.30.0 or lower and all of the following conditions apply:
- You are utilizing
flashMessagefeature. - User input or data from URL parameters is incorporated into the
flashMessage.
An example of a vulnerable snippet where query parameters are used to populate the text property of a flashMessage.
var params = new URLSearchParams(location.search);
var errorMessage = params.get('error__message');
var showParams = {};
if (!!errorMessage === true) {
showParams.flashMessage = {
type: 'error',
text: 'We were unable to log you in. ' + errorMessage,
};
}
lock.show(showParams);
OR
- You are utilizing
languageDictionaryfeature. - User input or data from URL parameters is used in
languageDictionaryproperties.
An example of a vulnerable snippet where query parameters are used to populate the socialLoginInstructions property of a languageDictionary.
var params = new URLSearchParams(location.search);
var instruction = params.get('instruction');
var options = {
languageDictionary: {
emailInputPlaceholder: "[email protected]",
title: "title",
socialLoginInstructions: instruction
},
};
var lock = new Auth0LockPasswordless(
CLIENT_ID,
DOMAIN,
options
);
lock.show()
How to fix that?
Upgrade to version 11.30.1.
Will this update impact my users?
The fix uses DOMPurify to sanitise the flashMessage and languageDictionary inputs. If you are including inline JavaScript in these fields, like script tags or onclick attributes, these will be removed.
🎯 Affected products1
- npm/auth0-lock:< 11.30.1