GHSA-jq57-3w7p-vwvvHighCVSS 7.5

Docassemble unauthorized access through URL manipulation

Published
February 29, 2024
Last Modified
March 21, 2024

🔗 CVE IDs covered (1)

📋 Description

Impact

The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96.

Patches

The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched.

Workarounds

If upgrading is not possible, manually apply the changes of 97f77dc and restart the server.

Credit

The vulnerability was discovered by Riyush Ghimire (@richighimi).

For more information

If you have any questions or comments about this advisory:

🎯 Affected products2

  • pip/docassemble.webapp:>= 1.4.53, < 1.4.97
  • pip/docassemble.base:>= 1.4.53, < 1.4.97

🔗 References (4)